ProfileLab Interface Elements

The following elements make up the workspace. Most elements can be moved around and docked in the workspace.

When you first start the application, or open a new file, the materialBlank Size dialog appears. Set the origin, orientation, dimensions, material, and resizing of the blank. To save your settings, click Advanced.

To make changes to what is visible in your workspace, use the View Menu.

Toolbars can be customized so your workspace has all of the quick buttons you need. This article displays default settings.

To customize a toolbar:

  1. Go to View > Toolbars > Customize, or right-click when your mouse is over a toolbar, then click Customize.
    The Toolbars dialog appears.
  2. Select the check boxes for the toolbars you'd like to see in the workspace.
  3. To customize, select a toolbar and click Customize.
    The Customize dialog appears.
  4. Add or remove buttons as required or click Reset, then Close.
  5. In the Toolbars dialog, select the size and type of icons you want to use, and if applicable, color icons.

For more information on specific tools, see Tools.

SmartBar

control-panel

From left to right:

  • Selected object (name is displayed)
  • Cursor coordinates
  • Units
  • Current nub (in red)
  • Anchor nub: Click to display anchor on object bounding box. Position it over a specific part of the shape and adjust the X and Y coordinates in the SmartBar. The anchor is adjusted to the new coordinates and when it is moved, the shape moves with it.
  • X, Y: Object coordinates
  • Horizontal dimension of object
  • Vertical dimension of object
  • Horizontal scale
  • Vertical scale
  • Proportion lock: Select to maintain aspect ratio when scaling.
  • Object rotation: In degrees.
  • Swatch: Select object color.

To edit the lightness or darkness of a color, double-click the color swatch on the SmartBar or in the palette, and in the General tab, use the slider to adjust.

Rulers and Guide Lines

The rulers run along the top and left edges of the workspace. The displayed units of measurement can be toggled in the options menu. Guide lines can also be placed beginning at the ruler.

  • Right click on a ruler to place a guide line at the point clicked.

  • Hover over the guide line and hold left click to drag the guide to a different location.

  • Hover over the guide line and press the delete key to delete the guide line(this will work even if objects are selected in the workspace).

Origin Point

To edit the origin point on the workspace, click and drag the upper left ruler () in the design area to the desired origin point (the cursor changes to a cross).


bonus-docBacking Up Fiery LLC Files, Workspace Objects


Note: Hover over buttons in the application to see actions.

System toolbar

system toolbar


Operations toolbar


Workspace toolbar

workspace toolbar


Compass toolbar

compass-toolbar


Toolbar


Palette toolbar and page numbers

palette toolbar overprint settings and page numbers

To edit a color, with the Select tool, double-click the color in the palette.

To enable or disable all Shop Palette colors except the current target fill color, press Alt and click the color.

To enable or disable a color, press Ctrl and click the color.

Pages

page-controls

Page 0 is the default workspace. When there are multiple pages, objects on Page 0 are visible on all pages.

Click to add, collapse, or delete pages.

Note: When collapsing pages, the offset value is in addition to the size of the blank (offset = blank size + offset value).

Note: If you have selected Do not allow page 0 objects to be modified on other pages on the General Options tab of the General Preferences dialog, page 0 objects are locked on other pages.


Material Blank

sign blank

bonus-docCustom Sign Blanks


Layer Viewer

The Layer Viewer is a tool that can float or be docked in the workspace. It is used to arrange workspace objects onto separate layers so portions of the design can be edited separately.

To enable the Layer Viewer, go to View > Layer Viewer. You can drag objects in this window to reorder them.

layer viewer

The buttons at the top, from left to right:

  • Add new layer
  • Delete layer
  • Edit (rename)
  • Show object attributes: Click to show attributes and operations applied to a selected object. Double-click to edit the object, or drag-and-drop to copy the attributes from one object onto other objects.
    object-attributes
  • Show context menu (on the left shows an object selected, on the right shows a layer selected)
    show-context-menucontext-menu-layer
  • Dock window

When a layer is selected, the following options appear:

  • Show layer: Toggle layer visibility.
  • Cut on/off: Enable or disable cutting.
  • Print on/off: Enable or disable printing.
  • Lock on/off: Lock to prevent objects from editing.

The bottom of the Layer Viewer window has an Object Picker. The object picker shows thumbnails for objects on the current layer. To select an object, use the drop-down arrow and then click a thumbnail.

If you turn off the layer viewer, you can merge all layers back into a single layer to make editing easier. Go to Show Context Menu and Merge All Layers. To always merge layers on import, see Merge layers on import.

bonus-docLayers