Supplementary English-Only Training Materials
Note: These materials are offered only in English as supplementary examples for a deeper dive into CADlink products.

Installation Instructions

This document explains how to install CADlink products.

This example uses SignLab and Visual Production Manager.

To skip to a section, use the links below:

Downloading the Application

If you already have the files locally, skip this section: Installing the Application.

  1. Open your web browser (Internet Explorer / Google Chrome / Firefox / Opera) and navigate to www.cadlink.com.
  2. Hover over LEARN & SUPPORT and select your product.
  3. Select DOWNLOADS.
  4. Click the icon for your product to download the files (for this example, SignLab).
  5. Navigate to the location you downloaded the .zip file, right-click, hover over Open with and select Windows Explorer (other extraction/unzipping software can be used).
    The Extract dialog appears.
  6. In the Compressed Folder Tools tab, select Extract all files.
    The Extract Compressed (Zipped) Folders wizard appears.
  7. Select or create a destination for the files, and when ready click Extract and open that location.
    The extraction time depends on your system performance and can greatly vary.
  8. If you have license files already, add them to this location so the installer can find them easily.

Note: If you have any security restrictions, such as Network/Internet Security, Anti-Virus, or Firewall applications installed and configured, you may need to contact IT for the access to perform the installation.

Installing the Application

Before starting the install, connect your dongle/USB Flash Drive.

  1. If not already in the folder where the files were extracted then navigate to it, open it and locate the file named setup.exe.
  2. Double-click to run the file, or if you have security or access restrictions, right-click and select Run as administrator.
    If the User Account Control appears, click Yes to allow the application to make changes to your computer.
    The Installation Wizard appears.
  3. Select the language and click OK.
    If your dongle is connected, click Next.
  4. If you wish to have access to plugins and scanning within your product, select 32-bit Windows Application. If not, select the recommended option: 64-bit, and click Next.
  5. Select Full install of SignLab Print and Cut and click Next.
    If desired, you can run the install again laterto install a stand-alone Production Spooler or the product plug-ins (the Send To feature for Corel/Illustrator/PhotoShop).
  6. Click Next again to proceed through the installation, review the license agreement, select I accept the terms of the license agreement, and click Next.
    Note: The directory by default will be C:\CADlink\Signlab 10.0 (It is recommended to leave the default directory but can be changed if required. Click Browse and find the desired location), then click Next.
    Depending on system performance, installation can take 5-20 minutes.
  7. When prompted to install cutting devices, make a selection and click Next.
    You'll need to select the device and the drivers.
  8. When prompted about font installation, Skip or Continue.
    You will need fonts installed for any text. You will also be prompted to search your drives for additional fonts to install. We recommend installing them.
  9. When the installation is complete, click Finish.

Your product is now installed and a Windows Explorer window should appear with a short cut from the Start menu to launch each products in your package. You can create a shortcut on your Desktop or pin the icon to the taskbar (right-click the design icon and select Pin to taskbar.

Launching the Application

  1. Launch the product from the desired shortcut and the application will load as required.
  2. To install devices, see Installing Output DevicesInstalling Output Devices.
  3. To set up the devices, see PlotterEngraverMachine Setup dialogManage devices.
  4. To set up the ports, see Choosing PortsPort Settings.
  5. If your device is a printer / laser printer, you may need to obtain the drivers from the manufacturer that is supported within your operating system.
    Note: If you are using an adapter, you may also need to obtain the drivers for the cable you are using; Parallel to USB or Serial to USB cables have specific drivers to make them work with Windows.
  6. Once the required drivers are installed and the port has been set, you should be able to test a cut or send a print via File > Print to a Windows printer.

Steps only for Visual Production Manager:

  1. If you want to use Visual Production Manager, go to File > Launch Visual Production Manager.
  2. Select Install Printer and select the printer, click OK and Next to install the driver, then Next and Finish to complete the driver installation for that device.
  3. Select a print mode then click Next.
    Complete the same steps to install a cutter when prompted.
  4. Continue through the wizard and select your desired material type, size, layout mode, registration system, and whether the jobs will be on Hold on import or otherwise.
  5. Once the wizard is complete, navigate to Queue > Manage Queues and ensure you have the correct port selected for the desired device(s).

Installation and set up is now complete. We recommend sending test prints/cuts.